Transition Editor

Transition editor (available as a device in the main window) is for editing a transition from one audio file (faded out) to the next one (faded in).



Using this editor is optional, the user can just change transition preset from Playback Ctrl (to such as Crossf 0.5s).




Changing transition type from Playback Ctrl without using transition editor.

This editor is not available unless mix mode is set to Automix and at least two songs have been added to main playlist. Songs also need to be preprocessed before the editing is allowed, during which the editor shows a progress bar.


Mix mode set to Auto (yellow led).


Songs have been added to the main playlist.


Songs are being preprocessed.

The editor has two waveforms:
on top, the waveform of the song to fade-out (showing end of that audio file).
below it, the waveform of the song to fade-in (showing beginning of that audio file, start time as set (cued) in deck with waveform and cueing).



This editor is for adjusting the following:
when to start fade out
how long to fade out (fade-out duration)

when to start the next song
and how long to fade that song (fade-in duration)

To scroll the waveform view, Press on the top wave and drag left/right, this does not affect the transition at all but is only for editing/viewing purposes.

Press and drag the bottom wave instead to adjust when to start playing the upcoming song, relative to the "fading out song" position. As an option, alt key may be held down to adjust fade-out start and this together.

Click at area just above the bottom wave to adjust duration of fade-in. To adjust fade-in middle point, press and drag the bottom wave within the fade-in length while holding down shift key and move up/down and left/right.

Click at area just above the top wave to adjust start of fade-out. As an option, alt key may be held down to adjust (start of the upcoming song) and this together.





Click at area just below the top wave and right from the fade-out start to adjust length of fade out. To adjust fade-out middle point, press and drag the top wave within the fade-out length while holding down shift key and move up/down and left/right.





Middle point of the fade-in/fade-out can be adjusted by holding the shift-key down and clicking within the fade.

Below the waveforms is an area with > icon to set the start time of prelistening, this is usually automatically adjusted when editing offsets or fade lengths.



At left side are popups with a default value "Volume". There transition can instead be set to fade filters (lowpass or highpass) instead of amplitude (volume). This filtering is also possible more advanced using transition effects described later in this file.



At right side from waveforms is a vertical zoom control to zoom in/out the waveforms.



Below it are two knobs, first knob (from left) changes "Trim Start" threshold from the default value for this single audio file, meaning that when adjusting this knob the "Trim Start" function is recalculated with this new threshold value. You'll notice the start time in the right deck display changes when this knob is adjusted (though not always as it is a threshold value).

Other songs edited in this editor at a later time stll use the default value as set in Mix menu > Playback Options, unless the knob is adjusted by the user again for the song.



The knob on right side changes the default for 'Trim End' threshold instead (for this single audio file). This recalculates the transition offset with this new set threshold value. This may be used for quickly adjusting the transition offset (alternative is to drag the bottom wave while holding down the alt-key).

[ ... ] button opens a menu to show/hide navigation and effects for the transition, these are also available from 'Devices' main menu.



Button ( > headphones ) to prelisten the transition with headphones, or if no headphones have been configured in audio preferences, it will play through main output. This prelisten does not use the actual decks A+B of main playback but instead uses two hidden players that are independent of the main playback, so the transition can prelistened while the decks are playing through speakers.



Solo switch to mute either of the songs from prelistening, so a fade or other property can be tested without the other song being audible, at setting OFF both are audible.



Transitions can be edited independently from main playback ahead, so you can navigate from editing transition 1-2 to 2-3 and 3-4 while song 1 is still playing in the main output. Navigation < > buttons to move up/down in the main playlist are above the transition editor and keyboard keys for these buttons can be set in Edit > Keyboard Setup, or you can double click an item in main playlist while holding alt-key (or right-click and select 'Edit Transition').










Currently edited transition is shown in the main playlist with an icon on the left side.

When navigation index is set to above the currently playing song, the normal decks A+B are hidden above the transition editor and the normally hidden transition prelisten players are instead shown and controlled by the Deck A+B viewer.

As a shortcut, the display device that shows times and song info "Current Song" can be double clicked to set transition editor to the song currently playing in main out and this connects the decks A+B viewer to the actual decks of the main output. This is same as clicking navigation < button repeatedly.


'Current Song' can be double clicked to show the main A+B players instead of the transition prelisten players.

Transition effects

Any number of effects may be included in a transition and this can greatly enhance the transition, such as multiple point filter adjustments, reverbation, ending song to a delay line, starting a song with varying delay etc...

If the transition effects is not shown below the editor, click [...] button and check 'Show Effects' or select 'Transition Effects' from main 'Devices' menu.



First popup menu from left now has the text "Current" (Left deck, the fading-out song). When this is selected the effects are added to the song which is fading out.

Click the popup menu to change it to "Next" (Right deck, fading-in song), this selects which one to edit, effects can be added for both.



Now, to add an effect to this transition, click "..." button in the transition effects and select "Edit Chain..." or select "Add ".



If you selected 'Edit Chain', a window opens, double click or drag one or more of the effects type to the list on the right side.



The effect should appear below. The round effect parameter knobs may be adjusted in the effect view.



Then select a parameter from third popup of the editor, most common parameter is dry/wet which controls how audible the effect is (dry is uneffected, wet is fully effected).



Then click 'Edit/Posit' button to enable effect edit mode, unless this button already has a label ( .... ). When enabled, the waveforms in the editor is switched from editing fade out/in lengths to editing effect parameters. The edit mode is also automatically enabled when mouse is hovered over the point editor area.





The transition editor waveforms should turn less visible. In the transition editor waveform area, set an area for the effect parameter points by clicking to set start and then drag to the right to set length, a box appears. If the effects are for the next song (fading in) click the bottom area instead.



The length and start can also be later adjusted with the arrows on left and right sides, the arrows appear when mouse is moved over the edge.



If later adjusting the length of the area with arrows on left/right sides, shift key can be held down to keep points in the current positions instead of scaling the values.

To again edit the normal fade-in/fade-out points in transition editor, click 'Edit/Posit' button again to hide the transition effect areas.

Now click inside the area box to add a point inside that box:
X (left - right) sets time position and
Y (up=100, down=0) sets the parameter value.

To remove a point, hold alt-key down and click on a point.



A larger point editing area is also available, it is shown/hidden by clicking the [ ... ] button of the transition effects and selecting "Point Editor". When using the larger editor, the start and length of the area is still edited in the waveforms area.





Instead of the larger point editor, if more height is needed for the point editing in the waveform area, a keyboard shortcut can be set.
Edit menu > Keyboard Controls, search for 'trans edit wave' and set a keyboard shortcut for it.



Reset button removes all parameter points and clears the set start/length.

Right-click reset button for more options:




Clear in/out
Clears points of this effect parameter from both fade-in and fade-out, this does not mean both fades in this current edit, instead, as a song is first faded-in you can add parameters to the fade-in and then the same song with same effect is set to fading out. (Song A plays and fades out, Song B fades in (1st), Song B fades out (2nd), Song C fades in....)

Clear
Same as clicking 'Reset' button with left-click (normal).

The following resets do not remove the set start/length and instead only replace the points with a preset:
0 0
0 1
1 0
Mid Up
Mid 2 Up
Mid Down
Mid 2 Down


When one effect parameter has been edited and you select another effect parameter to edit, that previous parameter is shown in the other (above or below) wave area as non-editable view only, this is for visual help.



C Copy button
Copies current effect parameter points, then select another parameter or another effect and click P to paste the parameter points there.



To copy all parameters of an effect instead of a single parameter, right click copy button instead and select 'Copy All Params' and then right-click P Paste button and select 'Paste All Parameters'.



At the right side is a button ONN | OFF, when set to OFF none of the effects are processed.



When a parameter is automated by adding the X,Y points to it, the parameter value set in the normal effect view (knobs) is ignored.

When audio effects are added to transitions, the effect tails (reverbation, echo...) can often last longer than the transition and stay audible for a while after the song has been changed and the transition has been finished.

If you need to clear an effect tail immediately for some reason, select 'Stop Effect Tails' from main 'Mix' menu.

These transition effects can also be used instead of transition/parameter automation for just adding specific effects to specific songs on the playlist. So reverb may be added for one song on the playlist while other songs are not effected.

In that case, all you need to do is add the effects and change some parameters by adjusting the knobs.

Playlist can be saved/copied including song start times, transition parameters and transition effect parameters. Click 'Save' above the main playlist and enter a name for the saved playlist. Another way is to create new playlist from "File" menu and then copy from the main playlist (Edit > Copy) and paste (Edit > Paste) the songs to the playlist in sources.