Edit Menu

Undo

Undo and redo are available for playlist editing.

Redo

-

Cut

Removes selected items from the playlist. If currently viewing library, items are removed from the library.

Copy

Copy and paste items between playlists.

Paste

-

Select All

Deselect All

-

Adjust EQs...

Low, mid high EQ knobs on the mixer, on decks C,D,E, on Comp and for main output.

The sound of these EQs/filters can be adjusted, you can alter the frequency and width of the filters.

Each of these three EQ knobs are made up of two filters:
Low EQ consists of a low-shelf filter (specific for low frequencies) and general band-pass filter (bottom).
Middle EQ consist of two band-pass filters.
High EQ consists of a high-shelf filter and a band-pass filter (bottom).





Browser Keys...

1-3 lists are available for narrowing down the song list/library:
View menu: List Browser, List Browser 1L (One list on the left side), List Browser 3R (Third list placed to the right side).


Browser list narrows list of songs to genres 'Ambient' and 'Electronic'

Fields of these lists can be changed in this window.
Defaults are genre, artist and album.

A quicker way to change the field is to simply right-click the list in the main window for a popup menu.



Columns...

Select which fields (columns) to show on song lists (such as title,artist,album, folder name...)

First popup menu from left selects current tab, this is same as changing tab in the main window.



Next a popup to select which list columns to edit.



Number of columns sets how many columns are from left to right. Rows allows to show song information fields on two or more lines. By default the main playlist of Disco XT uses three rows and the library uses only one row.




By default, the main playlist has two columns, three rows.


By default, the library has six columns on a single row.

A new column can be inserted to between columns by clicking 'Insert' or by right-clicking a column in the list of columns.

Select a column under 'Select' and then select a field from the list 'Value'.

To swap places of two fields click one field and then drag the mouse cursor above another field.

To copy columns of 'Library' to 'Main Playlist', select 'Library' then click 'Copy' and select 'Copy Library' then select 'main playlist' and click 'Paste' and click 'Paste to main playlist'.

Columns are setup separately for different lists: for library, for main playlist (automation list, usually on the right side of the main window), for playlist side editor that can be shown at left from library (can be shown from View menu), play logs is columns of library list when a play log has been selected from sources. File browser is columns of library when 'File Browser' has been selected from sources.

Columns are also setup separately for each tab. To copy the entire columns setup from one tab to another tab: Select tab to copy from, then select Edit menu > Columns... and click 'Copy' and select 'Copy All', then select tab to copy to (destination) and in the columns window click 'Paste' and select 'Paste All'. Or just click 'Paste' and select name of a tab (Paste All From ).



Columns can be auto sized (to show all text) in the main window by right clicking any of the columns.

Column Sorting...



Columns are sorted by clicking a column above a song list one or more times.
It can be set to 3 modes: no sorting, ascending (A or 0 first), descending (Z or 9 first).
In 'No sorting' mode, the order of items can be changed by dragging to a different position (unless viewing the main library), when a column is sorted this feature is disabled.

Column sorting specifies sorting rules where more than one field (column) is considered in the sort. For example, first sorting by artist name, then sorting those by album name: artist EEE: album AAA, album BBB...

Effect Presets...

If you have created presets (saved parameter settings) for audio effect units, those are listed here and can be deleted or renamed.

Hardware Controller...

Configure to use an USB connected device with buttons, knobs and/or sliders. Read topic 'MIDI'.

Keyboard Setup...

Customize menu keyboard shortcuts and create keyboard controls for features such as Deck:play, select library list etc.. (as an alternative, instead of clicking with a mouse). Read topic 'Keyboard Control'.

Song Colors...

Songs on lists can be right-clicked and in the popup-menu, a color can be selected for the selected songs. This may be useful to identify and separate songs on lists for visual purposes. In this window, you select how many colors are available (1-10) and adjust the colors. Each color consists of 4 definable colors: for background (behind text), for selected background (behind text when the song is selected) and for text and for selected text.

Color is adjusted using 3 sliders: From top: click to select a color (hue), then select between light or strong color, then between dark or light color. Current color is shown below these 3 sliders. Above the first slider, are C Copy and P Paste buttons to copy colors from one place to another.

Tabs...

Tabs are pages with different content (song lists, devices). One tab (page) could show decks A+B and mixer, another tab could show a sampler, another tab would be to use the full screen size for viewing library etc...

In the tab editing window...
First, on left top, is the list of tabs.
Click + (plus) to add a new tab page and X to remove the current tab page.
At right from the tab list, a name field for the tab page.





Then drag items from "Not Shown" to "Shown" list (or double click). "Shown" lists devices added to this tab and "Not Shown" lists devices available. This can be done in the main window too, from 'Devices' and 'Decks' menus.



In addition to the devices shown, there are three elements available: Sources (List of playlists), library (shows content of library and content of playlists) and main playlist (a playlist used for playback/Automix/audio exporting).



Commonly all three elements are shown.
In Disco XT built-in default tab setup, in "Mixer" tab (planned for non-automix crossfader-mixing) the main playlist is not selected and is hidden.

For using on a small screen, option is available to double the width/height of the screen area for the library/playlist, then a keyboard shortcut (default shift+X shift+Y) may be used to switch to the other side of the interface.

Device placement can be changed, default is top left (meaning that devices will be shown above these three list elements and if one of the elements is selected to show next to devices, it will be on the right side.

One of these three elements can be put next to devices, if there is enough screen space, On a 1024 width display this is not possible as the devices in Disco XT are 1024 pixels width, but on 1400 pixel wide and larger displays this is suitable.


Main playlist is on the right side from the devices.

A simple preview of the current tab layout is shown, where these three list elements are shown as boxes and labels. You can click a box there to swap places.



'Apply' applies made changes to the main window.

There are several view options available for the list elements under 'View' menu in the main window, such as an option to to show prelistening player or narrowing lists.

Sub-Tabs...

These are tabs/pages inside the main tabs, each showing one or more device items. These may or may not be helpful for organizing the multiple elements of the program. A device can be shown by either adding it to a sub-tab page in this edit window and then selecting that page in the sub-tabs in the main window, or by selecting a device by name from "Devices" menu (this places it to the main tab, not to sub-tabs). A device placed to sub-tabs can be hidden by selecting it from 'Devices' menu.



Select to edit either A or B sub-tab page list.
+ (plus) button to add a new sub-tab page, and X to delete current sub-tab page.

Drag items to the page, from "Not Shown" list to "Shown" list (or double click).

The sub-tab edited can be shown by selecting "Sub-Tabs A/B from 'Devices' menu.

Transitions...

Transition presets include fade-in, fade-out and offset values that define the length and style of transition: transition can be several seconds or less than a second, silence can be set between songs...

In this window, transitions can be renamed, deleted and new transitions can be created. There is a "group" field below the name field: this is to place transitions to sub menus when selecting a transition from the main window, so long list of transitions can be split to several groups.





Fade-out, fade-in and offset values out values are given as ms. 1 second = 1000 ms.
Offset value of 0 means that the two songs do not cross-play at all.
offset value of 1000 means that there is a 1 second gap/silence between songs.
Offset is usually set to a negative number similar to that of fade-in or fade-out.



There are two knobs for both of the fades to set a middle point for fade, first knob sets offset of the middle point, second knob sets the amount.



Audio sample can be attached to a transition, select a file by clicking the folder icon or record with microphone, then set proper start / length by dragging the sliders below the audio waveform, or double click on an empty area to move the start there. Move the bar between fade-in and fade-out in the fade viewer to adjust starting time of the sample (or adjust the offset knob).

Another way to create transition presets is to use transition editor in the main window and right-click the editor and click 'Save...'. Those saved transitions cannot be edited in this window and show up as 0,0,0.


Saving transition preset directly in the transition editor in the main window.

'For Fade Out' and 'For Pause Playlist' are special transitions used when right-clicking song list and selecting 'Insert pause playlist/fade-out...'. For more information, read "Right-click song' menu. If you happen to delete these presets, the presets are recreated next time used.

Transition Rotation...

Option to change transition type after each transition: this creates some variation to transitioning in auto mix mode. 'Rotation' button enables this mode, drag transitions to the list on right side and change the order of the transitions if needed.

This can also be done manually by selecting a transition from 'Playback Ctrl' device or by right-clicking transition editor.



-

Erase App Data and Close...

Confirms twice, then deletes all user data and temporary files of Disco XT and then closes the program. Use this before uninstalling if you wish to discontinue using the software. Optionally, this menu item can be hidden from the edit menu by selecting hide in preferences > Misc.