View Menu
Most list elements (sources, library, list browsers, main playlist) can be resized by clicking on left/right side of
the list box and then dragging left/right.

Full Screen
(Mac OS X only)
Hides other applications and sets the main window to fit entire screen, menu bar is hidden and can be shown
by moving cursor to top of the screen.

Menubar in Window
(Mac OS X only)
Shows an alternative Disco XT version of the main menu bar within the main window.

View Keys...
Shows current keyboard controls. Double click in the window to close it. This a larger size visual key list, to
edit keyboard controls: Edit menu > Keyboard Setup....

View Keys (Current Group)...
Same as View Keys, but if a keyboard group has been selected, keys of that group are shown instead, "View
Keys" shows keys of the main group.

List Alphabets

Shows alphabets A-Z above library for jumping to that position. The letters might be greyed out until the list
is sorted by clicking a column above the song list. Then click letter to scroll to position of first appearance, or
click twice to last appearance of that letter.

List Artwork Browser
Shows artwork images attached to audio files. If no artworks are shown, Select File menu: Read Artwork to
read artworks to Disco XT image cache.
Click an image to select and list files with that artwork, other items are then hidden from the list. Once image
is selected, it can be unselected by clicking to another artwork or by clicking 'X' button shown inside the
artwork image. Artworks can be dragged to lists to quickly add the contained audio files. Arrows are placed
on left and right sides to navigate between artwork pages, or use mouse scroll wheel to scroll the artworks.
In Edit > Preferences, some artwork browser options are available, such as hiding the arrows and adjusting
image crossfade duration.
Click and hold just below the artwork browser and drag up or down to adjust size of the artwork images.

List Browser

Disco XT: 05_View Menu

Page 1

List browsers narrow the selected playlist or library by selecting one or more genres, artists, folders etc.
If List Browser 2 is not checked and list browser 1L is not checked and List Browser 3R is not checked, then
this shows three lists above the library. The keys selected on list 1 (on left side) narrow down the keys on list
2 (at middle) and the key selected on list 2 narrow down keys of the last key list on right side, so selecting a
genre from the first key list narrows down artists on list 2 to the selected genres, and selected artists narrow
down to selected albums from those artists.
Height of browser can be resized by clicking below the browsers and then hold and drag up/down.
If List Browser 1L is selected, list 1 will be placed to the left side from library.
If List Browser 3R is selected, list 3 will be placed to the right side from library.
On Mac, holding shift and command keys can be used to select multiple keys,
and shift and control keys on Windows.

Key of a list can be changed by right-clicking on a list browser.

List Browser 2
Same as previous, except that only 2 lists are shown instead of 3. If List Browser 1L and List Browser 3R are
selected, only one list is shown.

List Browser 1L
Places a browser list to the left side from the song list.

List Browser 3R
Places a browser list to the right side from the song list.

List Helper Buttons

Shows buttons above the library, from left: Detect BPM for selected, edit info of selected, show artwork
browser, show list browser, show alphabets. All of these are available from File and View menus and so
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having these buttons shown is optional.

List Player

Shows a small prelistening player above the library. Double click item on the list to prelisten. Player has time
elapsed on left side and timeline on right side. Click the time elapsed to also play/pause the player (and
default keyboard shortcut is the space key) and click the timeline to change position.
The width of this prelisten player can be changed in Preferences > Misc.
Although not set up by default, there are more keyboard controls available for this player than the space key
(such as go to file start, back 2 seconds...), listed in Edit menu: Keyboard Setup: Decks Oth: Deck list pre....

List Waveform

Shows a waveform (amplitudes/peaks) of the song being prelistened. On the right side of the wave is a zoom
control to zoom in/out in the wave, or right-click the zoom-control to toggle on/off entire wave mode that
shows the entire song in the waveform.

List Bookmarks
For storing one or several time positions of the file being prelistened. These are available after closing and
reopening the program and available when the file is later loaded to decks A or B (and C,D,E).

- minus button to remove the current bookmark.
+ button to add a new bookmark (to the end of bookmark list).
< > to navigate in created bookmarks.
Cue button sets the prelistening player position to the current bookmark.
Play/pause button.
Set button stores the current prelistening position as the current bookmark, another option is to click 'Cue'
and then adjust the position by dragging the waveform left/right, the wave needs to in zoomable and not in
entire view mode for this.
Each bookmark can be named, double click the field right from 'Set' button to enter a new name for the
bookmark. First bookmark is always named 'Cue'.
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List Tabs
Shows tabs above the library, usually by default there should be an item named "Library" in the list and (+)
button to add a new tab. Library tabs are used to store multiple views of the library simultaneously. For
example first searching for 'Electronic then selecting artists from list browser, then clicking (+) button to add
a new tab and change the view to something else (such as changing search terms), then going back to that
'Electronic' view by clicking on the tab name.

By default, a new tab is added automatically when typing a new search to the search field. This can be
changed in Preferences > Misc > "Search entry to new lib tab" and also see the next item there "Remove lib
tab when clearing search field".
In File menu are available:
New List Tab
Remove List Tab
Remove Other List Tabs

List Stats
Below the library are shown: name of currently viewed playlist, number of items, duration of all items together
and number of selected items.

List Side Editor

Side editor is between the sources list and the library list.

Shows a small playlist editor at right side from sources (at left from library).
This can be useful for creating a new list of songs by navigating within the library and dragging songs to that
side editor while still keeping the library view.
Another way is to drag songs from the library to above a playlist name in sources.
Another way is to drag the songs first to main playlist or requests lists on the right side and then save it as a
playlist later.
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When 'Side Editor' is enabled all editable playlists open in the side editor list, non-editable playlists such as
the Library and iTunes playlists load to the Library list. By default, side editor only has one column "Title" this
can be changed if needed from Edit menu: Columns.

List Horizontal Scrolling

In case many information columns are required (such as composer, grouping...) and there isn't enough width,
horizontal scroll bars can be enabled to scroll the list horizontally.

Sources with Library
Includes the sources/list of playlists next to the library music list within the same view item. This is usually
not needed, but if the library is set to 'Next to Tevices' in Edit menu > Tabs, this allows to include the playlist
list there.

File Browser Locations

When 'File Browser' has been selected from 'Sources', additional list "Locations" is shown at the left side from
library. These can be clicked to set file browser to that location. Items can be drag and dropped from the
library to this "Locations" list.

Main Playlist Waveform
See "List Waveform" above.
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Main Playlist Player
See "List Player" above.

Main Playlist Split
For splitting the file being prelistened to two or several parts. You create split marks and then after all marks
have been created, click 'Split' button and the file on main playlist will be replaced with multiple copies p1/3
p2/3 (parts) The button (1) can be clicked later to remove the splitted items and instead show it as a single
item. These splitting functions only changes some values within Disco XT and do not alter the original audio
files in any way. The split marks are available after exitting and relaunching Disco XT.

The first mark 'Cue' sets the beginning of the audio, only the second item (after clicking +) adds a split
marker.
click '+ Plus' button to add a marker. then adjust the marker position. Then click '+ Plus' button again to add a
new marker and then adjust the position of that marker.

- minus button to remove current mark.
+ button to add a new mark.
< > to navigate in created marks.
After the file has been splitted by clicking 'Cue', the first item should be navigated to 'Cue'.
When a splitted file is shown in the Transition editor, the transition editor does show (and allow editing) audio
after the mark but instead adds a white or dark line to indicate the split mark. Otherwise this works just like a
normal end-of file.

Setting split mark position
Cue button sets the prelistening player position to the current bookmark.
Play/pause button.
Set button stores the current prelistening position as the current bookmark, another option is to click 'Cue'
and then adjust the position by dragging the waveform left/right, the wave needs to be in zoomable and not
in entire view mode for this.

Main Playlist Requests

When 'Main Playlist Requests' is selected from 'View' menu, a button to show either the requests or the main
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playlist (automation list) is shown above the main playlist.
Using requests is optional, purpose of the requests list is to have some clear space for song selecting and
song ordering to be played in the future apart from the main playlist which is connected to the decks A+B.
To move songs from requests list to main playlist and vice versa, drag songs above the buttons to change the
list to view and then drop the songs to that list. Songs can also be moved by selecting and then clicking '<->'
button right from 'Requests' button. Or by right-clicking a song and selecting 'Move to ...'

Main Playlist Toolbar

Shows a group of buttons above the main playlist, from left to right:
Move selected items down by one.
move selected items up by one.
move selected items to the top of main playlist (if currently playing the top most songs, then the songs are
placed below it instead).
X remove selected items.
Shuffle selected items or, if only 1 or none are selected, the entire main playlist is shuffled (except the top
most songs if the songs are playing). Shuffle is a random order separation function.
+ button to insert a special track to the main playlist to the current position.
'Copy to Source' asks for a name, then saves the content of the main playlist to the sources as a new playlist.
This includes any transitions, transition effects, start times, gain and tempo adjustments, so the playlist is
playable exactly as it was created here,

Main Playlist Stats
See "List Stats" above.

Main Playlist Horizontal Scrolling
See "List Horizontal Scrolling" above.

Artwork Within Deck
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An artwork image is shown (if available) instead of jog wheel in the decks A+B. Only valid if not using the
smaller size version of the decks A+B.

Artwork At Sides
If there is unused space on the left and right sides of the devices, the artworks of the decks A+B are shown
there.

Artwork for Selected Song
An artwork image of the currently selected item in the library is shown in the sources list. When mouse is
moved above the sources list the image is hidden.

Content Colors...
To customize images and colors of the Disco XT user interface.
First is a popup to select an image folder, included are two image folders: Inverted and grey. Inverted is
default white skin, grey is a dark grey skin.

When only changing colors, click 'Apply' instead. There are several colors to edit, selected from the Color
popup menu.
Color is adjusted using three sliders: From top: click to select a color (hue), then select between light or strong
color, then between dark or light color. Current color is shown below these 3 sliders. Above the first slider,
are C Copy and P Paste buttons to copy colors from one place to another.

display = color of display background of decks and others.
display text = text color of deck displays and others.
icon = some texts in the interface etc...
some control bagkr = ...
Disco XT: 05_View Menu

Page 8

list=color of list rows
list row 2 = color of every other list row (row 2, row 4....)
list text = text color of list row
list misc = some separator lines etc.
list sel text = text color of a selected row.
list sel = color of selected rows.
menu = color of main menu and popup menus
menu sel = menu selected item color
menu text = menu text color
menu text sel = menu selected text color
icon B = ...
column text + some = ...
window backgr = general and window background color
level meters mostly = level meters color
wave grid = color of the beat grids in the 'Compile Layers' feature.
Colorize = First select the image folder '1_inverted' then adjust this color, then click 'Colorize Images' button
and an image folder is created with the color defined here. This allows to colorize the image files of Disco XT
easily. If you instead select '0_grey' as the image folder to colorize, select 'Lighten instead of darken' and the
last of the color sliders (white/black) adjusts lightness instead of darkness.
If you have an image editing application, and wish to alter the default images, duplicate either one of the
default image folders and edit image files in that folder (do not duplicate the masks folder, as that is used by
all image folders together). Some interface elements such as displays are created by code within the program
and are not editable as an image and some image elements are used in multiple places.
On Windows, images are in the program folder in Programs > Disco XT > Disco XT. On Mac OS X, right-click
Disco XT and select 'Show Package Contents' and navigate to Resources > images.
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